查看: 715|回复: 2

Dom7 导致 swiper5 4 等不能再IE11上渲染 导致项目崩溃

[复制链接]

该用户从未签到

1

主题

2

帖子

7

积分

新手上路

Rank: 1

积分
7
发表于 2020-1-6 17:03:05 | 显示全部楼层 |阅读模式
环境 :  vue 脚手架  4.1.2
          swiper:5.1.0
表现为:

ie11表现

ie11表现
追踪后  是 Dom7 的空间命名   class Dom7{} 的问题   由此看出是Dom7存在问题


新测试:   用 vue-cli 3   4.1.2 创建新的项目   QQ浏览器 IE模式下 可打开    加入 swiper:5.1.0 后  就报错了   表现同上  追踪后 错误位置变化   但也基本确定是Dom7捣的鬼

求教   咋解决 兼容 ie 11 的版本  
回复

使用道具 举报

该用户从未签到

0

主题

13

帖子

23

积分

新手上路

Rank: 1

积分
23
发表于 2020-5-25 11:58:04 | 显示全部楼层
欢迎收藏我们168开奖网,在这里您可以查到最新最快的彩票开奖信息,更有:福彩双色球幸运飞艇,等丰富彩种,而且免费提供每期的玩法给大家参考.
回复 支持 反对

使用道具 举报

  • TA的每日心情
    慵懒
    2020-8-11 17:27
  • 签到天数: 1 天

    [LV.1]初来乍到

    0

    主题

    2

    帖子

    14

    积分

    新手上路

    Rank: 1

    积分
    14
    发表于 2020-8-11 17:27:07 | 显示全部楼层
    参考VUE-CLI官方https://cli.vuejs.org/zh/guide/b ... ility.html#polyfill 浏览器兼容性:
    如果该依赖基于一个目标环境不支持的 ES 版本撰写: 将其添加到 vue.config.js 中的 transpileDependencies 选项。这会为该依赖同时开启语法转换和根据使用情况检测 polyfill。
    所以干脆将Swiper所引用的包都在vue.config.js中配置上即 transpileDependencies: ["swiper","vue-awesome-swiper","vue-slick-carousel","dom7"]
    回复 支持 反对

    使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    Archiver|手机版|小黑屋|Swiper中文网 ( 粤ICP备15001020号

    GMT+8, 2020-9-25 08:48 , Processed in 0.102962 second(s), 32 queries .

    Powered by Discuz! X3.2

    © 2001-2013 Comsenz Inc.

    快速回复 返回顶部 返回列表